Upload of .csv data


#1

Hi!

I’m trying to upload to openSenseMap some data recorded by a Arduino-based mobile station, in .csv format. Every time I try to upload the file I get an “Invalid filetype” error

An example line from the .csv file:
5d68db3b953683001a9a9fea,20,2020-01-06T14:10:27Z,25.98,44.45,0

If I copy the same data into the Measurement data field, it works fine. However, this is difficult to do with large amounts of data.

If I record data in .json format, I can upload it:
[
{“sensor”:“5d68db3b953683001a9a9fea”,“value”:“20”,“createdAT”:“2020-01-06T14:10:27Z”,“location”:[25.98,44.45,0]}
]

Still, I would prefer the .csv format, as it’s much simpler to implement in code.

Any ideas? What I’m doing wrong???


#2

Hi @Electronza,

I just tried to reproduce the issue but uploading a CSV file did work in my case. Maybe you can upload your CSV file or a snippet so that I can check what’s wrong


#3

Hi @Felix

Below is an example of .csv file I tried to upload on https://opensensemap.org/account/____/dataupload.

test.csv

I tried both with Chrome and Mozilla, with the same error message.


#4

Hi @Electronza,

thanks for your sample file. Uploading the file on https://opensensemap.org/account/____/dataupload works without any issue (tested on Chrome and Safari on macOS). The only problem I found was the trailing comma at the end of the line. After deleting this comma and changing the sensor id I was able to upload the data.

Can’t you even upload the small sample CSV file you provided?


#5

I work on a Win10 PC. I was finally able to upload the data if I change the extension of the file to .json - now the file is test.json, albeit its content is in csv format.