Der von opensensemap gesendet Sketch kann nicht mehr compiliertwerden Fehler: Senseboxio.h fehlt


#1

Die unten stehende Fehlermeldung erhalte ich wenn ich den von opensensemap geschickten Sketch versuche zu kompilieren.

im März hat es noch funktioniert.

Hat jemand eine Lösung ?

Arduino: 1.8.8 (Windows 10), Board: “Arduino/Genuino Zero (Programming Port)”

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Stefan\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Stefan\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries D:\Users\Stefan\Documents\Arduino\libraries -fqbn=arduino:samd:arduino_zero_edbg -vid-pid=0X04D8_0XEF67 -ide-version=10808 -build-path C:\Users\Stefan\AppData\Local\Temp\arduino_build_794168 -warnings=none -build-cache C:\Users\Stefan\AppData\Local\Temp\arduino_cache_319927 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.bossac.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0 -prefs=runtime.tools.bossac-1.7.0.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.arm-none-eabi-gcc-4.8.3-2014q1.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.arduinoOTA.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.2.0 -prefs=runtime.tools.arduinoOTA-1.2.0.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.2.0 -prefs=runtime.tools.openocd.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\openocd\0.9.0-arduino6-static -prefs=runtime.tools.openocd-0.9.0-arduino6-static.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\openocd\0.9.0-arduino6-static -prefs=runtime.tools.CMSIS-Atmel.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0 -prefs=runtime.tools.CMSIS-Atmel-1.1.0.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0 -prefs=runtime.tools.CMSIS.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0 -prefs=runtime.tools.CMSIS-4.5.0.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0 -verbose D:\Users\Stefan\Documents\Arduino\sensebox\sensebox.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Stefan\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Stefan\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries D:\Users\Stefan\Documents\Arduino\libraries -fqbn=arduino:samd:arduino_zero_edbg -vid-pid=0X04D8_0XEF67 -ide-version=10808 -build-path C:\Users\Stefan\AppData\Local\Temp\arduino_build_794168 -warnings=none -build-cache C:\Users\Stefan\AppData\Local\Temp\arduino_cache_319927 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.bossac.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0 -prefs=runtime.tools.bossac-1.7.0.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.arm-none-eabi-gcc-4.8.3-2014q1.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.arduinoOTA.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.2.0 -prefs=runtime.tools.arduinoOTA-1.2.0.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.2.0 -prefs=runtime.tools.openocd.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\openocd\0.9.0-arduino6-static -prefs=runtime.tools.openocd-0.9.0-arduino6-static.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\openocd\0.9.0-arduino6-static -prefs=runtime.tools.CMSIS-Atmel.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0 -prefs=runtime.tools.CMSIS-Atmel-1.1.0.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0 -prefs=runtime.tools.CMSIS.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0 -prefs=runtime.tools.CMSIS-4.5.0.path=C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0 -verbose D:\Users\Stefan\Documents\Arduino\sensebox\sensebox.ino
Using board ‘arduino_zero_edbg’ from platform in folder: C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.6.21
Using core ‘arduino’ from platform in folder: C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.6.21
Detecting libraries used…
“C:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++” -mcpu=cortex-m0plus -mthumb -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -fno-threadsafe-statics -nostdlib --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -w -x c++ -E -CC -DF_CPU=48000000L -DARDUINO=10808 -DARDUINO_SAMD_ZERO -DARDUINO_ARCH_SAMD -D__SAMD21G18A__ -DUSB_VID=0x2341 -DUSB_PID=0x804d -DUSBCON “-DUSB_MANUFACTURER=“Arduino LLC”” “-DUSB_PRODUCT=“Arduino Zero”” “-IC:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0/CMSIS/Include/” “-IC:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0/CMSIS/Device/ATMEL/” “-IC:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.6.21\cores\arduino” “-IC:\Users\Stefan\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.6.21\variants\arduino_zero” “C:\Users\Stefan\AppData\Local\Temp\arduino_build_794168\sketch\sensebox.ino.cpp” -o nul
sensebox:57:24: error: senseBoxIO.h: No such file or directory

#include <senseBoxIO.h>

                    ^

compilation terminated.

exit status 1
senseBoxIO.h: No such file or directory


#2

Hast das richtige Board in der IDE eingestellt?


#3

Danke das war der Fehler. Ich hab halt keine Erfahrung damit und probiere so ein bisschen herum.