API lesen in FHEM


#1

Über meine Haussteuerung FHEM will ich die senseBox über das API einbinden. Mittels HTTPMOD (ein FHEM-Modul das an anderen Stellen funtioniert) rufe ich die URL meiner senseBox auf: https://api.opensensemap.org/boxes/5e60f87357703e001be9fbaa/sensors 120 . 120 ist das reload Intervall. Dabei wird mir ständig “502 Bad Gateway” zurückgeliefert und die Verbindung geht kurzzeitig verloren. Der vollständige gelieferte Header:

HTTP/1.0 502 Bad Gateway
Content-Type: text/plain; charset=utf-8
X-Content-Type-Options: nosniff
X-Frame-Options: DENY
X-Xss-Protection: 1; mode=block
Date: Tue, 24 Mar 2020 10:45:56 GMT
Content-Length: 16

Rufe ich die selbe URL im Browser auf, so ist das Resultat fehlerfrei.


#2

Hallo,

was heißt “ständig”? Immer oder bei jedem zweiten Request?

Viele Grüße,
Gerald


#3

ständig.

Kann es sein dass ich zu oft abfrage? Dzt jede Minute.


#4

Ist jetzt in FHEM anders (mittels neueren Moduls “JsonMod”) gelöst und läuft mittlerweile fehlerfrei.

Danke und LG
Karl