Problem with connecting to the server and outputting data to the OLED display.

wifi
opensensemap

#1

Hello!

I became the proud owner of sensebox =)
I am a newbie, so please do not be angry for possibly stupid questions, Iā€™m just starting my way with this device.

After assembling the device, I ran into some problems:

  1. When I turn on the WIFI connection check, I get an error:
    "
    Connecting to WiFi ā€¦ connected!
    Calling openSenseMap server ā€¦ failed after 3 trys!
    Disconnecting from WiFi.
    "
    At the same time, ping internet-test.testing.opensensemap.org from the computer and the phone does not work (exceeding the waiting interval), and the use of mobile communications to connect did not bring any result.
    Wifi Bee Version 19.5.4

I am in Ukraine, can this be a problem for the connection?

And question number 2:
I have an OLED display, and I was able to display dust sensor readings in real time on it.
But I can not find information how to display information from two other sensors.

I have a Light and UV Sensor and a Temperature and Humidity Sensor.

I apologize for my English. In German, I would not be able to ask a question at all. =)
Thank you in advance for your response!


#2

Hi @Killjaen,

glad to hear you are a proud owner of a senseBox and welcome to our forum.
There are no stupid questions :wink: and asking questions in english is also fine.

I have an answer to your question 1 regarding the Wifi connection check:
We moved to a new infrastructure and the endpoint internet-test.testing.opensensemap.org is not available anymore. There is a pending Pull Request on Github for it. In the meantime change the endpoint to internet-test.opensensemap.org and the connection check should be successful.

If you are still having problems connecting your senseBox check out the Guide for upgrading the Wifi Bee Firmware https://sensebox.github.io/books-v2/home/en/additional-info.html

@Jan or @mario can help you with question 2.


#3

Hi @Killjaen,

regarding question 2:
Are you working with the Arduino IDE or with the Blockly Interface?
If you want to Display more than one reading you have to adjust the Y-Coordinate in the Code. In fontsize 1 you will need to set it to 8 to print a Value in the second line.

If you say in which Programming interface you are working I think I can help you more specific.

Best
Mario